В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
радмирик
радмирик
05.07.2021 05:54 •  Информатика

Составить программу вычисления стоимости покупки N тетрадей и M ручек.

в программе КуМир.

Показать ответ
Ответ:
ggggeorgiyggg
ggggeorgiyggg
23.05.2021 02:54

Привет!))) Я составил несколько алгоритмов, можешь просмотреть их ниже)))

Алгоритм №1

1) Начало

2) Вскипятить чайник

3) Положить заварку в кружку

4) Залить кипятком

5) Подождать 5 минут

6) Конец

Алгоритм №2

1) Начало

2) Достань ключ из кармана

3) Вставь в замочную скважину

4) Поверни ключ два раза

5) Вытащи ключ

6) Конец

Алгоритм №3

1) Начало

2) Выкопать ямку

3) Опустить в ямку саженец

4) Закопать ямку с саженцем

5) Полить саженец водой

6) Конец

Объяснение:

Линейный алгоритм – это алгоритм, в котором все действия выполняются последовательно одно за другим. Используя блок-схемы, линейный алгоритм можно представить следующим образом: Примером линейного алгоритма может быть вычисление периметра прямоугольника с заданными сторонами.

Надеюсь, что я , пока!)))

0,0(0 оценок)
Ответ:
cat159753jjyfvb
cat159753jjyfvb
11.12.2020 16:20

Відповідь:

#include <iostream>

using namespace std;

const int size = 4;

void inputarr(int *arr,const int size){

for(int i = 0 , counter = 1; i < size; i++, counter++){

 cout << "Введите " << counter << " число: ";

 cin >> arr[i];

}

}

void sortarr(int *arr,const int size){

for(int i = 0; i < size - 1; ++i){

 int biggest = i;

 for(int j = i + 1; j < size; ++j){

  if(arr[j] > arr[biggest]){

   biggest = j;

  }

 }

 

 swap(arr[i],arr[biggest]);  

}

}

void printarr(int *arr,const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int main(){

setlocale(LC_ALL, "Rus");

int arr[size];

inputarr(arr,size);

cout << "Изначальное положение: ";

printarr(arr,size);

cout << "\nРезультат: ";

sortarr(arr,size);

printarr(arr,size);

return 0;

}

Использовал одномерный массив и сделал сортировку методом выбора по убыванию

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота