В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
takhtarkina
takhtarkina
24.05.2020 22:43 •  Информатика

Напишите программу для суммы числового ряда. дан числовой ряд и малая величина е(эпсила). найдите сумму ряда с точностью е(0,001), общий член которого задан формулой

Показать ответ
Ответ:
shakmatovakseni
shakmatovakseni
26.08.2020 19:22
Чтобы излишне не терять точность и не тратить лишнее время на вычисления, выведем рекуррентную формулу.
\displaystyle a_1= \frac{3}{2}; \\ \\ a_{i-1}=\frac{3^{i-1}\cdot (i-1)!}{[2(i-1)]!}; \\ \\ a_i=\frac{3^i\cdot i!}{(2i)!} = \frac{3\cdot3^{i-1}\cdot i\cdot(i-1)!}{2 i\cdot(2i-1)\cdot(2i)!}={ \frac{3i}{2i\cdot(2i-1)}\cdot a_{i-1}=\frac{3}{4i-2}\cdot a_{i-1}
В задании не сказано точно, как определять условие окончания суммирования. Примем, что суммирование завершается, если очередной член ряда не может изменить накопленную сумму больше, чем на ε, т.е.
|aₓ| ≤ ε.

// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (ai1,eps,s,i):=(3/2,0.001,3/2,2);
  while true do begin
    var a:=3/(4*i-2)*ai1;
    if Abs(a)>eps then begin i+=1; s+=a; ai1:=a end
    else Break
    end;
  Writeln('S = ',s:0:3)
end.

Результат
S = 2.532

Напишите программу для суммы числового ряда. дан числовой ряд и малая величина е(эпсила). найдите су
0,0(0 оценок)
Ответ:
polinaponomare1
polinaponomare1
26.08.2020 19:22
//Pascal
//Функция факториала
function fact(n: integer): real;
begin
  if (n = 0) then fact := 1
  else fact := n * fact(n - 1);
end;

//Main
var
  a: real;
  n, lim: integer;
begin
  write('Введите n: '); readln(n);
  lim := n; a := 0;
  for n := 1 to lim do
  begin
    //a := a + (power(3,n)*fact(n))/fact(2*n);
    a := a + (exp(ln(3)*n)*fact(n))/(fact(2 * n));
  end;
  writeln('a = ', a:5:3);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота