Написать в C# и составить блок-схему: Напишите программу, которая выводит на экран фразу «Всем привет» 80 раз – в таблице из 20 строк по 4 столбца. Для расстояния между колонками использовать 5 пробелов
Для начала переведем в десятичную 7*1+2*9+1*81=106. Перенесем 24 вправо 106-24=82. Число = Нужно 82 перевести в другую систему, вопрос в какую. Честно говоря взял наугад 7 (основание должно быть явно меньше 10 и даже 9). Делим нацело 82/7=11 + 5 остаток (это будет младший разряд) теперь делим 11/7=1+4 (остаток будет второй цифрой) и единичка (на 7 больше не делится) будет самым старшим разрядом.
Теперь, как я понял, нужно перевести в троичную (если другое число, не 82, то переведите по примеру). 82/3=27+1(остаток, младший разряд), 27/3=9+0(0 это следующий разряд), 9/3=3+0 (0 это третий разряд), 3/3=1+0 (0 это четвертый разряд), и осталась единичка, которая на 3 не делится (нет целой части от деления). Это будет самый старший разряд. Получили.
1в.
1)Код Pascal
begin
write('N = ');
readln(N); { <-- вводим трехзначное число }
writeln;
N := N mod 100; { <== Последние две цифры }
{ Выводим последнюю и среднюю цифры числа: }
writeln('Последняя цифра: ', N mod 10);
writeln('Средняя цифра: ', N div 10);
readln
end.
2)
var
N: word; { Трехзначное число }
t1, t2, t3: byte; { Цифры трехзначного числа }
begin
write('Введите трехзначное число: ');
readln(N); { <-- вводим трехзначное число }
writeln;
t3 := N mod 10; { <== третья цифра }
N := N div 10; { <== число созданное первыми двумя цифрами }
t2 := N mod 10; { <== вторая цифра }
t1 := N div 10; { <== первая цифра }
writeln('Сумма цифр: ', t1 + t2 + t3);
readln
end.
Объяснение:
Для начала переведем в десятичную 7*1+2*9+1*81=106. Перенесем 24 вправо 106-24=82. Число = Нужно 82 перевести в другую систему, вопрос в какую. Честно говоря взял наугад 7 (основание должно быть явно меньше 10 и даже 9). Делим нацело 82/7=11 + 5 остаток (это будет младший разряд) теперь делим 11/7=1+4 (остаток будет второй цифрой) и единичка (на 7 больше не делится) будет самым старшим разрядом.
Теперь, как я понял, нужно перевести в троичную (если другое число, не 82, то переведите по примеру). 82/3=27+1(остаток, младший разряд), 27/3=9+0(0 это следующий разряд), 9/3=3+0 (0 это третий разряд), 3/3=1+0 (0 это четвертый разряд), и осталась единичка, которая на 3 не делится (нет целой части от деления). Это будет самый старший разряд. Получили.