В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
181101s
181101s
07.04.2020 15:45 •  Информатика

Будьте милосердны Составьте программу, в которой описывается массив из записей Ведомость на заработную плату. В ней содержаться данные: ФИО работника, его оклад в день, количество отработанных дней в месяце, а также заработную плату за месяц, которая должна подсчитываться самой программой. Выведите ведомость на экран.

2) На основе созданного массива записей, подсчитайте всю сумму к выплате заработной платы всех работников этого предприятия.

3) На основе созданного массива выведите фамилию работника с самой низкой заработной платой. Если их несколько, выведите всех.

Показать ответ
Ответ:
Crackstack18
Crackstack18
25.03.2023 22:35
Var
  ar: array[1..10]of integer;
  i, c, s: integer;
 begin
  s := 0;
  c := 0;
  randomize;
  for i := 1 to 10 do ar[i] := random(-10, 10);
  writeln('Полученный массив:');
   for i := 1 to 10 do write(ar[i], ' ');
  writeln;
  for i := 1 to 10 do if(ar[i] <> 0) then c := c + 1;
  writeln('Количество ненулевых элементов = ', c);
  for i := 1 to 10 do if(ar[i] <> 0) then s := s + ar[i];
  writeln('Сумма всех его ненулевых элементов = ', s);
  write('Их среднее арифметическое = ',s/c);
end.
0,0(0 оценок)
Ответ:
mvalinka
mvalinka
24.11.2021 11:51
Единицы измерения информации 
В 1 бит можно записать один двоичный символ.
1 байт = 8 бит
В кодировке ASCII в один байт можно записать один 256 символьный код
В кодировке UNICODE один 256 символьный код занимает в памяти два байта
1 килобайт = 1024 байт
1 мегабайт = 1024 килобайт
1 гигабайт = 1024 мегабайт
1 терабайт = 1024 гигабайтФормула Хартли 2 i = N где i- количество информации в битах, N - неопределенностьТаблица степеней двойки, которая показывает сколько информации можно закодировать с бит i012345678910N=2 i12481632641282565121024Чтобы вычислить информационный объем сообщения надо количество символов умножить на число бит, которое требуется для хранения одного символа

Например: двоичный текст 01010111 занимает в памяти 8 бит 
Этот же текст в кодировке ASCII занимает 8 байт или 64 бита 
Этот же текст в кодировке UNICODE занимает 16 байт или 128 бит. 



0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота