В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
coffeepro80
coffeepro80
02.04.2020 00:02 •  Информатика

Написать три программы на паскале. 1) составить программу для вычисления площади, периметра и длины диагонали. 2)составить программу для нахождения суммы, разности, произведения, частности введенные с клавиатуры. 3) дано: треугольник abc произвольный. составить программу для вычисления его площади.

Показать ответ
Ответ:
zhivotkhanova95
zhivotkhanova95
07.10.2020 15:15
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Укажите длины сторон прямоугольника:');
  Writeln('Площадь=',a*b,', периметр=',2*(a+b),
      ', диагональ=',Sqrt(a*a+b*b):0:5)
end.

Пример
Укажите длины сторон прямоугольника: 13.6 8.4
Площадь=114.24, периметр=44, диагональ=15.98499

begin
  var (a,b):=ReadReal2('Введите a и b:');
  Writeln('a+b=',a+b,', a*b=',a*b,', a/b=',a/b)
end.

Пример
Введите a и b: 134.23 -15.7
a+b=118.53, a*b=-2107.411, a/b=-8.54968152866242

begin
  var (a,b,c):=ReadReal3('Введите стороны треугольника:');
  var p:=(a+b+c)/2;
  Writeln('S=',Sqrt(p*(p-a)*(p-b)*(p-c)):0:3)
end.

Пример
Введите стороны треугольника: 13 8 11.3
S=44.843
0,0(0 оценок)
Ответ:
irinkagoncharo
irinkagoncharo
07.10.2020 15:15
Если надо на паскале, то вот 2й номер.

program calc;
var  a, b, c: real;
var  d: integer;
begin  write('Введите числа (Внимание, если вы хотите произвести вычитание/деление, то введите уменьшаемое/делимое число первым.');  readln(a, b);  write('Введите код операции. 1-сложение. 2-вычитание. 3-умножение. 4-деление.');  readln(d);  case d of     1: c := a + b;    2: c := a - b;    3: c := a * b;    4: c := a / b;  else    writeln('Ошибка');  end;  writeln('ответ:', c);end.
Написать три программы на паскале. 1) составить программу для вычисления площади, периметра и длины
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота