Напишите программу на python, которая считывает два натуральных числа a и b и выводит наибольшее значение из них. При решении задачи можно пользоваться только целочисленными арифметическими операциями + , −, ∗, //, %, =. Нельзя пользоваться такими конструкциями как: ветвления, циклы, функции.
ответ:
расчерти таблицу , в один столбик слева запиши фамилии, сверху профессии
и начинай заполнять.
петров и гришин никогда не держали малярной кисти- ставь минус напротив их фамилии они точно не маляры.
.иванов и гришин всё собираются посетить мельницу, на которой работает их товарищ. ставь минус напротив их фамилии они точно не мельники.
когда все отметишь остануться пустые клеточки там поставь +
у тебя должно получиться иванов-парихмахер
петров плотник
сидоров мельникгришин почтальон
алексеев маляр
весь смысл в таблице, без неё тяжеловато
!
подробнее - на -
объяснение:
nomer3
program ab;
uses crt
uses sysutils;
var s,s1: string;
i,j: integer;
begin
clrscr;
write('введите строку слово');
writeln;
readln(s);
for i: =1 to length(s) do
for j: =1 to length(s) do
if (s[i]=s[j]) and(i< > j)
then
if pos(s[i], s1)=0
then s1: =s1+s[i]+' ';
write('повторяющиеся символы: ', s1);
readln;
end.
nomer2
program as
uses crt;
var s,sp: string;
i: integer;
begin
clrscr;
write('s=');
readln(s);
sp: ='';
for i: =1 to length(s) do
sp: =s[i]+sp;
if sp=s then writeln ('палиндром')
else writeln ('не палиндром');
readkey
end.
nomer1
function compare(s1,s2: string): boolean;
begin
result: =s1=s2;
end;
var s1,s2: string;
begin
readln(s1);
readln(s2);
if compare(s1,s2) then write('yes')
else write('no')
end.