В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lchayanb17
lchayanb17
22.12.2021 04:29 •  Информатика

Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. окончание ввода – число 0. протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. паскаль

Показать ответ
Ответ:
Kotik77789
Kotik77789
15.06.2020 23:46


uses crt;
var x,min,max:integer;
begin
clrscr; min:=0;max:=0;
Writeln('Write x = ');
readln(x);
min:=x;
max:=x;
while x<>0 do
begin
readln(x);
if ((min > x) and (x<>0)) then min:=x;
if ((max < x) and (x<>0)) then max:=x;
end;
writeln('max = ',max);
writeln('min = ',min);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота