В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ВанькаНер
ВанькаНер
10.10.2020 23:55 •  Информатика

Написать программу вычисления площади треугольника если известны его стороны. С++ Что исправить на фото? ​


Написать программу вычисления площади треугольника если известны его стороны. С++ Что исправить на ф

Показать ответ
Ответ:
Gsjhcf
Gsjhcf
01.12.2021 15:21

1. Для записи алгоритмов используют несколько словесный

графический

программный

Словесный – это записи алгоритма на естественном языке, но с тщательно отработанным набором слов и фраз, не допускающих повторений, синонимов, двусмысленности, лишних слов. Допускается использование математических символов. При графическом описания алгоритма осуществляется с блок-схем. Программный это запись алгоритма на языке программирования (в виде компьютерной программы).

2. Налить 9 литров. Перелить в другое ведро 5 литров. В 9-ти литровом останется 4 литра. Из 5-ти литрового вылить воду. Перелить из 9-ти литрового оставшиеся 4 литра в 5-ти литровое ведро. Наполнить 9-ти литровое ведро водой. Перелить в 5-ти литровое ведро 1 литр (больше в 5-ти литровое не влезет). Из 5-ти литрового вылить воду. В 9-ти литровом останется 8 литров. Перелить в 5-ти литровое ведро. ИТОГ: в 9-ти литровом останется 3 литра.

3. Прямоугольник - блок вычислений

Ромб - условие

Параллелограмм - блок ввода-вывода данных

овал - начало и конец алгоритма

Стрелки, соединяющие эти фигуры, и задают порядок выполнения действий.

0,0(0 оценок)
Ответ:
Rekryt123
Rekryt123
23.01.2022 05:04

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота