В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyaborisova13
nastyaborisova13
10.07.2021 11:18 •  Информатика

Написать программу ввода 30 элементов одномерного массива, введенных случайным образом.

Показать ответ
Ответ:
sashasas12365
sashasas12365
03.09.2020 01:56
Var
  x, y, rx, ry: real;
  n: integer;
  s: string;

begin
  writeln('Введите два положительных числа');
  readln(x, y);
  writeln('Введите код операции от 1 до 4');
  readln(n);
  case n of
    1: begin rx := sin(x); ry := sin(y); s := 'sinX' end;
    2: begin rx := cos(x); ry := cos(y); s := 'cosX' end;
    3: begin rx := tan(x); ry := tan(y); s := 'tgX' end;
    4: begin rx := 1 / tan(x); ry := 1 / tan(y); s := 'ctgX' end;
  else begin rx := 0; ry := 0; s := '???' end
  end;
  writeln('Результаты для ', s, ': ', rx, ', ', ry)
end.

Тестовое решение:

Введите два положительных числа
4 5
Введите код операции от 1 до 4
2
Результаты для cosX: -0.653643620863612, 0.283662185463226

Сделайте программу и блок-схему к : даны два действительных положительных числа x и y. тригонометрич
0,0(0 оценок)
Ответ:
Dasha846363737
Dasha846363737
30.01.2023 06:15
Uses crt;
var i,zi,zj:integer;
    s,n:String;
begin
clrscr;
repeat
writeln('Введите строку не больше 20 символов.');
readln(s);
until length(s) <=20;
for i:=1 to length(s) do
begin
if (s[i] = 'm') or (s[i]='м') then
 begin
      n:=copy(s,i,3);
      if n = 'max' then begin n:='min'; delete(s,i,3); insert(n,s,i); zi:=zi+1; end
      else
      begin
      n:=copy(s,i,4);
        if n = 'Макс' then begin n:='Мин'; delete(s,i,4); insert(n,s,i); zj:=zj+1; end; 
      end;
end;
end; 
if (zi <> 0) or (zj <> 0) then writeln('В строке заменено ',zi,'раз. слово "max".  А слово "макс" ',zj,'  раз.')
else writeln('В строке не найдено совпадений для замены...');
writeln;
writeln(s);
Readkey;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота