В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
adilimanaliev03
adilimanaliev03
16.03.2020 20:50 •  Информатика

Написать программу в scilab, которая выдает все двухзначные числа кратные заданному числу​

Показать ответ
Ответ:
жека12рус
жека12рус
20.11.2021 01:25

===== PascalABC.NET =====

function S(a: array[,] of integer) :=

a.Cols.Where(p -> p.All(q -> q >= 0)).SelectMany(p -> p).Sum;

function M(a: array[,] of integer): integer;

begin

 var n := a.RowCount;

 Result := integer.MaxValue;

 var s: integer;

 for var i := 0 to n - 2 do

 begin

   s := 0;

   for var j := 0 to i do

     s += Abs(a[i - j, j]);

   if s < Result then

     Result := s

 end;

 for var j := 1 to n - 1 do

 begin

   s := 0;

   for var i := n - 1 downto j do

     s += Abs(a[i, n - i + j - 1]);

   if s < Result then

     Result := s

 end

end;

begin

 var n := ReadInteger('n =');

 var a := MatrRandom(n, n, -10, 30);

 a.Println;

 S(a).Println;

 M(a).Println;

end.


Написать программу обработки двумерного массива. дана целочисленная квадратная матрица. определить:
0,0(0 оценок)
Ответ:
opasno10
opasno10
19.03.2023 14:30

#include <iostream>

using namespace std;

int main () {

   int n;

   cin >> n;

   if (n==0) {

       cout << "0  0" << endl << 1 << endl << 1 << endl;

       return 0;

   }

   int mx=0; int mn=10; int mxi=10; int mnk=0; int ind=0;

   while (n>0) {

       int c=n%10;

       n/=10;

       if (c>=mx) {

           mx=c;

           mxi=ind;

       }

       if (c<mn) {

           mn=c;

           mnk=1;

       } else if (c==mn) {

           ++mnk;

           ++ind;

       }

   }

   cout << mx << " " << mn << endl << (ind - mxi) << endl << mnk << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота