В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kiriolet
kiriolet
06.05.2021 01:28 •  Информатика

Написать программу в паскале. за ранее . на одномерный массив. 3. даны два массива a и b, состоящих из одинакового числа элементов. найти среднее арифметическое элементов каждогомассива и сравнить эти значения. заполнение массива выберите по своему усмотрению.

Показать ответ
Ответ:
olga638
olga638
01.10.2020 07:07

var

  a,b:array [1..10] of integer;

  i:integer;

  s1,s2:real;

begin

  randomize;

  for i:=1 to 10 do begin

   a[i]:=random(12)-1;

   s1:=s1+a[i]; 

   b[i]:=random(9)+1; 

   s2:=s2+b[i]; 

   write (a[i],' ');

  end;

  writeln;

  for i:=1 to 10 do write (b[i],' ');

  writeln;

  s1:=s1/10;

  s2:=s2/10;

  writeln ('S1 = ',s1);

  writeln ('S2 = ',s2); 

  if s1>s2 then writeln ('S1>S2') else

  if s1<s2 then writeln ('S1<S2') else writeln ('S1=S2');

  readln;

end.

0,0(0 оценок)
Ответ:
kissssss7s8
kissssss7s8
01.10.2020 07:07

uses crt;
var
  a,b:array [1..100] of integer;
  i,k:integer;
  Sa,Sb:real;
begin
  write('Введите количество элементов массивов: '); read(k);
  clrscr;
  randomize;
  writeln('Массив А:');
  for i:=1 to k do
  begin
    a[i]:=random(50)-25;
    b[i]:=random(100)-50;
    Sa:=Sa+b[i];
    Sb:=Sb+a[i];
    write (a[i]:4);
  end;
  writeln; writeln('Массив В:');
  for i:=1 to k do
    write (b[i]:4);
  writeln;
  Sa:=Sa/k; Sb:=Sb/k;
  writeln ('Сумма элементов массива А: ',Sa);
  writeln ('Сумма элементов массива В: ',Sb);
  if Sa>Sb then writeln ('Ср.(А)>Ср.(В)')
  else
    if Sa<Sb then writeln ('Ср.(А)<Ср.(В)')
  else writeln ('Ср.(А)=Ср.(В)');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота