В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gadukina
gadukina
17.02.2022 12:52 •  Информатика

Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит максимальный элемент и выведет его на экран.

Показать ответ
Ответ:
SilvAqualius
SilvAqualius
15.01.2021 00:21

сначала надо отсортировать массив.

я отсортировал по убыванию и вывел первый элемент, т.е максимальный

Объяснение:

const

m = 10;

var a: array[1..m] of integer;

i,j:integer;

begin

for i:=1 to m do begin

  read(a[i]);

end;

for i:=1 to m-1 do

  for j:=1 to m-i  do

    if a[j] < a[j+1] then begin

      swap(a[j],a[j+1]);

    end;

    writeln;

 for i:=1 to m do

   write(a[i],' ');

   writeln;

   writeln(a[1]);

end.

0,0(0 оценок)
Ответ:
dashamaltseva64
dashamaltseva64
15.01.2021 00:21
PascalABC.NET

Кратчайшее решение:

### RAI(10).Max.Pr

Другое из множества возможных решений:

##var a := ReadArrInteger(10);var max := a.Max;Print('Максимальный элемент:', max)
Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит макс
Написать программу, которая сначала обеспечит ввод 10 чисел в одномерный массив, затем вычислит макс
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота