Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
BandiMatrix
06.05.2020 23:27 •
Информатика
Написать программу в паскале. даны два числа.меньшее из них замените полусуммой этих чисел, а большее - их произведением. составить блок-схему.
Показать ответ
Ответ:
noxiksds
02.10.2020 19:48
Var a,b:integer;
begin
writeln('a=');
readln(a);
writeln('b=');
readln(b);
if (a>b) then begin
b:=(a+b)/2;
a:=a*b;
end
else
begin
a:=(a+b)/2;
b:=a*b;
end;
writeln('a=',a, ' b=', b);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
JOKER7500
15.02.2020 20:24
Запишите выполнение приведенного фрагмента для табличной величины значениями элементов который являляются числа 2; -2 ;3; 0,25; -4 .dob:= 1; for i :-1 to 5 do dob :- dob...
2000lev94
20.10.2021 23:44
Ввести предложение без знаков препинания и в предложении переставить слова в порядке неубывания числа букв в словах.ввести новое предложения в , заранее...
genek711
26.01.2020 23:18
Браузер internet explorer произвел перекодировку информационного сообщения на языке, первоначально записанного в 16-битном коде unicode, в 8-битную кодировку кои−8. при...
prizrak6571
26.09.2020 16:26
Проаналізуйте будь-яку пам’ятку української художньої культури....
ryslanka154
05.09.2022 00:58
Определить энергию связи атомного ядра марганца ( 55 25 Mn )...
Настя272724555257224
05.09.2022 00:58
За 5 дней путешественники проследовали 110 км дороги. если они пройдут ежедневно на 5км больше, чем в предыдущем дне. найдите сколько км путешественники в последний день?...
levonaleqsanya
05.09.2022 00:58
На предприятии до технического перевооружения годовой объем товарной продукции составлял 200 тыс. ед. по 2 тыс. руб. каждая, а затраты на ее производство и реализацию...
Зефирка78
05.09.2022 00:58
2. ответить письменно на вопрос: «Люди «дна»: характеры и судьбы» 3. ответить письменно на вопрос: «Что лучше для человека: жалость или истина?» (При ответе опирайтесь...
Roflobara
30.11.2020 19:22
ABCDA1B1C1D1 – прямоугольный параллелепипед. Диагональ B1D равна , а угол B1DВ равен 45 градусов . Диагональ основания BD образует со стороной ВС угол, равный 30 градусов...
чибик228
30.09.2020 14:04
Точки P и Q - середины рёбер AD и CC1 куба ABCDA1B1C1D1 соответственно . Докажите , что прямая BQ перпендикулярна прямой B1P. ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
writeln('a=');
readln(a);
writeln('b=');
readln(b);
if (a>b) then begin
b:=(a+b)/2;
a:=a*b;
end
else
begin
a:=(a+b)/2;
b:=a*b;
end;
writeln('a=',a, ' b=', b);
readln;
end.