В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SiRuES
SiRuES
16.04.2020 14:35 •  Информатика

Написать программу в паскале. дан массив размера n. 1. найти количество участков к, на которых его элементы монотонно возрастают.

Показать ответ
Ответ:
Никто25555
Никто25555
06.10.2020 04:19
Const n=20;
var a:array[1..n] of integer;
i,k,m:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:3);
 end;
writeln;
k:=0; m:=0;
for i:=1 to n-1 do
 begin
 if a[i+1]>a[i] then begin m:=m+1; end
 else begin if m>0 then k:=k+1; m:=0; end;
 end;
if m>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Массив A:
  7 30 22  0 17  4  2 32 39 26 23 41  1 38 47 21 38 31 43  7
k = 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота