В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
enbasmanovan
enbasmanovan
26.05.2023 17:53 •  Информатика

Написать программу в паскаль
Дан целочисленный массив размера NN, содержащий ровно два одинаковых элемента. Найти номера одинаковых элементов и вывести эти номера в порядке возрастания.

Показать ответ
Ответ:
arsenii2309
arsenii2309
03.09.2020 17:27

Variant 1

var

 A: array[1..100] of integer;

 N, i, j: byte;

begin

 write('N = ');

 readln(N);

 for i := 1 to N do

 begin

   write('a[', i, '] = ');

   read(a[i])

 end;

 writeln;

 for i := 2 to N do

   for j := 1 to i - 1 do

     if a[i] = a[j] then begin

       writeln('Номера: ', j, ' и ', i);

       exit

     end;

 writeln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота