В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Dahsa007
Dahsa007
21.09.2020 06:49 •  Информатика

написать программу в pascal, которая выводит числа из диапазона от 72 до 134, удовлетворяющие условиям: 1. вывести все чётные числа; 2. вывести числа, оканчивающиеся на "3"; 3. вывести числа, сумма цифр которых меньше 11.

Показать ответ
Ответ:
Alle963
Alle963
10.02.2021 23:03

Код программы:

var i, sum, a:integer;

begin

 writeln('Четные числа:');

 for i:= 72 to 134 do begin

   if i mod 2 = 0 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, оканчивающиеся на "3":');

 for i:= 72 to 134 do begin

   if i mod 10 = 3 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, сумма цифр которых меньше 11:');

 for i:= 72 to 134 do begin

   a:= i;

   sum:= 0;

   while a <> 0 do begin

     sum := sum + a mod 10;

     a := a div 10;

   end;

   if sum < 11 then

     write(i, ' ');

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота