В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
RitaMur
RitaMur
06.10.2020 16:14 •  Информатика

Написать программу с использованием условного оператора, условной операции, оператора switch (на выбор один из ) определяющее расположение точки А (х,у)
относительно заштрихованной области.


Написать программу с использованием условного оператора, условной операции, оператора switch (на выб

Показать ответ
Ответ:
Onewood
Onewood
22.08.2021 09:05

{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}

//pascal abc.net v3.0 сборка 1111

var

  a,i,b,r,n,j,bug: integer;

  s,se,slo,slof: string;

procedure preob(var a,b,n: integer; var se: string);

  begin

  repeat

    b: =a mod n;

    a: =a div n;

    str(b,se);

    s+=se;

  until (a< =n-1);

  end;

beginreadln(slo);

readln(n);

for j: =1 to length(slo) do

begin;

a: =ord(slo[j]);

preob(a,b,n,se);

str(a,se);

s+=se;

for i: =1 to length(s) div 2 do

begin;

se: =s[i];

s[i]: =s[length(s)-i+1];

s[length(s)-i+1]: =se[1];

end;

write(s,'-');

slof: =slof+s;

delete(s,1,length(s));

end;

end.

пример ввода:

работа на завтра.

2

пример вывода:

11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

0,0(0 оценок)
Ответ:
Arina5751
Arina5751
01.06.2020 21:14

Объяснение:

для начала переведем все цифры в килобайты

10 мегабайт= 10 000 килобайт

4 мегабайт= 4 000 килобайт

                     2 048 килобайт

                      4 096 килобайт

сложим полученные результаты

10 000+4 000+2 048+4 096=20 144 килобайт

переведем размер свободного места на флешке в килобайты, то есть

32 мегабайта= 32 000 килобайт

теперь от размера свободного места отнимем размер файлов

32 000-20 144=11 856 килобайт

переведем полученный результат в мегабайты

11 856 килобайт= 11,856 мегабайт

округляем, и получаем 12 мегабайт

ответ: То есть свободного места останется 12 мегабайт

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота