В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Angelina5353
Angelina5353
23.07.2020 01:11 •  Информатика

1. составить алгоритм и программу для вычисления значения функции по заданному значению аргумента.
2. составить алгоритм вычисления функции по заданным параметрам и значению аргумента
(паскаль) ​

Показать ответ
Ответ:
craisler320
craisler320
10.10.2020 07:48

program Calc1;

var

 m, k, x, y: Double;

begin

 Write ('Введите m, k, x: ');

 ReadLn (m, k, x);

 if m * k - x >= 2 then

   y := Sqr (x) + Sin (6 * x) - (k + 1)

 else

   y := Power (x, 3) - m * k + 3;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

program Calc2;

const

 E = 1;

 F = -2;

var

 x, y: Double;

begin

 Write ('Введите x: ');

 ReadLn (x);

 if x > Pi then

   y := Sqr (Pi) + E * x * Ln (x)

 else if x < 0 then

   y := 0

 else

   y := Pi / 4 - F * x;

 WriteLn ('y = ', y :20 :10);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота