В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Columbos
Columbos
23.11.2021 16:11 •  Информатика

Написать программу с циклом for для подсчета кубов чисел от 1 до N
PascalABC.NET 8 класс.

Показать ответ
Ответ:
Jackichan89
Jackichan89
09.12.2021 14:59
Var
 X1,Y1,X2,Y2,X3,Y3:real;
 A,B,C:real;

Begin
Write('X1 = ');ReadLn(X1);
Write('Y1 = ');ReadLn(Y1);
Write('X2 = ');ReadLn(X2);
Write('Y2 = ');ReadLn(Y2);
Write('X3 = ');ReadLn(X3);
Write('Y3 = ');ReadLn(Y3);
A:=sqrt(sqr(X2-X1) + sqr(Y2-Y1) );
B:=sqrt(sqr(X2-X3) + sqr(Y2-Y3) );
C:=sqrt(sqr(X3-X1) + sqr(Y3-Y1) );
if (A<B+C)and(B<A+C)and(C<A+B) then
Begin
WriteLn('Длины сторон равны:');
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
X1:=(A+B+C)/2;
WriteLn('Площадь треугольника равна ',sqrt(X1*(X1-A)*(X1-B)*(X1-C)))
End
else WriteLn('Треугольник не существует')
End.
0,0(0 оценок)
Ответ:
Дашунич
Дашунич
08.08.2021 05:39
Алгоритм на условном языке.

m:=0.  "количество отрицателных"
p:=0    "количество положительных"
i:=1.
пока i<>0 повторять
    i:=прочитать число, введенное с клавиатуры.
    если i>0 то p:=p+1.
    если i<0 то m:=m+1.
конец цикла пока.
вывести на экран('процент положительных = ', p/(p+m)).
вывести на экран('процент отрицательных = ', m/(p+m)).

Алгоритм будет верно работать, если введено хотя бы одно число, отличное от нуля. В противном случае возникнет ошибка деления на ноль. В нормальных программах подобные случаи отлавливаются и корректно обрабатываются.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота