В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Lera111katy
Lera111katy
11.11.2021 08:12 •  Информатика

Написать программу, подсчитывающую количество чисел (среди введенных с клавиатуры N чисел), кратных 5. И результат вывести на экран.

Показать ответ
Ответ:
annachernaya04ow7wxu
annachernaya04ow7wxu
17.07.2022 09:43
//где-то не закрыла begin end
var A:array [1..40] of integer;
sa,s3,s10,k,i: integer;
begin
sa:=0;
s10:=0;
s3:=0;
k:=0;
writeln('исходные значения');
for i:=1 to 40 do
begin
 A[i]:= random(21);
write(A[i],'')
end;
writeln;
for i:=1 to 40 do
 begin
 if A[i]mod 2<>0 then
begin
 sa:=sa+A[i];
k:=k+1;
if A[i]<10 then s10:=s10+A[i];
if A[i] mod 3=0 then
s3:=s3+A[i];                                     //здесь было странное выражение   
end;
end;                                                  //здесь
writeln('среднее арефмитическое нечетных чисел',sa/k:5:0);
writeln('сумма чисел, не превышающих', s10);
writeln('сумма чисел, кратных трем', s3);
End.
0,0(0 оценок)
Ответ:
viktoriakruminaВика
viktoriakruminaВика
07.06.2021 02:13

Для начала, переведем код в десятичную систему счисления.

110100102 = 21010

110011002 = 20410

110011112 = 20710

110100112 = 21110

Получаем: 210 204 207 211

Зная, что буква «А» кодируется как 192, а код каждой последующей буквы на 1 больше кода предыдущей буквы. Определим код остальных букв и расшифруем наше слово.

А-192

Б-193

В-194

Г-195

Д-196

Е-197

Ё-198

Ж-199

З-200

И-201

Й-202

К-203

Л-204

М-205

Н-206

О-207

П-208

Р-209

С-210

Т-211

У-212

Ф-213

Х-214

Ц-215

Ч-216

Ш-217

Щ-218

Ъ-219

Ы-220

Ь-221

Э-222

Ю-223

Я-224

СЛОТ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота