В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
1048298
1048298
08.04.2022 22:02 •  Информатика

Написать программу по вычислению 7!, используя цикл с предусловием(1) и использую цикл с параметром (2)

Показать ответ
Ответ:
Pemo
Pemo
11.10.2020 23:36

Объяснение:

Программа на питоне

a=1

for i in range(1,8)

a = a*i

0,0(0 оценок)
Ответ:
ulyanasims
ulyanasims
11.10.2020 23:36

C предусловием:

var

 i, y: integer;

begin

 y := 1;

 i := 7;

 while i > 1 do

 begin

   y := y * i;

   i := i - 1;

 end;

 writeln('Цикл с предусловием, факториал равен: ', y);

end.

C параметром:

const n=7;

var

i, s: integer;

begin

 s := 1;

 for i := 1 to n do

   s := s * i;

 writeln('Цикл с параметром, факториал равен: ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота