Написать программу по информатике в паскале художник сергей петрович рисует большую картину за неделю, а маленькую за день. рассчитайте все возможные варианты рисования им картин за n недель.
1 program z; var i : integer; begin Writeln('Введите число'); Readln(i); if i mod 2 = 0 then Writeln('Число чётное') else Writeln('Число не чётное'); readln; end.
2 program z; var i : integer; begin Writeln('Введите число'); Readln(i); if i mod 3 = 0 then Writeln('Число делится на 3') else Writeln('Число не делится на 3'); readln; end.
3 program z; var i: array[1..6] of byte; x:byte; begin for x:=1 to 6 do
begin Writeln('Введите ', x,' цифру из 6 '); Read(i[x]); end; if (i[1]+i[2]) = (i[4]+i[5]+i[6]) then Writeln('Билет счастливый') else Writeln('Билет не счастливый'); Readln; end.
5))) program z; var i : integer; begin Writeln('Введите число'); Readln(i); if i mod 6 = 0 then Writeln('Число делится на 6') else Writeln('Число не делится на 6'); readln; end. 6 program z; var a,b:integer; begin Writeln('Введите число A'); Readln(a); Writeln('Введите число B'); Readln(b); if b mod a = 0 then Writeln('Число А делится нацело на число В') else Writeln('Число А не делится нацело на число B'); Readln; end.
type massiv = array [2..21] of integer; var mass : massiv; i, summa : integer;
begin summa := 0; for i:=2 to 21 do begin mass[i]:=i; if (mass[i] mod 2 = 0) then summa := summa + mass[i] end; writeln('Сумма четных эл-тов равна : ', summa); readln; end.
program z; var a : array[2..21] of integer; i,summ : integer; b : array[2..21] of integer;
begin for i:= 2 to 21 do begin a[i]:=i; end;
for i:=2 to 21 do begin if a[i] mod 2 = 0 then begin b[i]:=a[i]; end;
end;
summ:=0; for i:=2 to 21 do begin summ:=summ+b[i]; end; Writeln(summ); readln;
program z;
var
i : integer;
begin
Writeln('Введите число'); Readln(i);
if i mod 2 = 0
then
Writeln('Число чётное')
else
Writeln('Число не чётное');
readln;
end.
2
program z;
var
i : integer;
begin
Writeln('Введите число'); Readln(i);
if i mod 3 = 0
then
Writeln('Число делится на 3')
else
Writeln('Число не делится на 3');
readln;
end.
3
program z;
var
i: array[1..6] of byte;
x:byte;
begin
for x:=1 to 6 do
begin
Writeln('Введите ', x,' цифру из 6 ');
Read(i[x]);
end;
if (i[1]+i[2]) = (i[4]+i[5]+i[6])
then
Writeln('Билет счастливый')
else
Writeln('Билет не счастливый');
Readln;
end.
5)))
program z;
var
i : integer;
begin
Writeln('Введите число'); Readln(i);
if i mod 6 = 0
then
Writeln('Число делится на 6')
else
Writeln('Число не делится на 6');
readln;
end.
6
program z;
var
a,b:integer;
begin
Writeln('Введите число A'); Readln(a);
Writeln('Введите число B'); Readln(b);
if b mod a = 0
then Writeln('Число А делится нацело на число В')
else Writeln('Число А не делится нацело на число B');
Readln;
end.
massiv = array [2..21] of integer;
var
mass : massiv;
i, summa : integer;
begin
summa := 0;
for i:=2 to 21 do
begin
mass[i]:=i;
if (mass[i] mod 2 = 0) then
summa := summa + mass[i]
end;
writeln('Сумма четных эл-тов равна : ', summa);
readln;
end.
program z;
var
a : array[2..21] of integer;
i,summ : integer;
b : array[2..21] of integer;
begin
for i:= 2 to 21 do
begin
a[i]:=i;
end;
for i:=2 to 21 do
begin
if a[i] mod 2 = 0 then
begin
b[i]:=a[i];
end;
end;
summ:=0;
for i:=2 to 21 do
begin
summ:=summ+b[i];
end;
Writeln(summ);
readln;
end.