Написать программу по этой на паскале
что будет выведено на экран в результате работы програм-мы? нарисуйте дерево рекурсивных вызовов функции f(5). алгоритм вычисления значения функции f(n), где n – натуральное число, задан следующими соотношениями: f(1) = 1 f(n) = f(n–1) * (n + 2), при n > 1 чему равно значение функции f(5)?
что не может быть одновременно x1=0 y1=0 z1=0
рассмотрим первое уравнение, это логическое умножение, каждый сомножитель должен быть равен 1, такое будет, если:
(не х1 + х2) * (не х2 +х3) *(не х3 +х4) * ( не х4 +х5) = 1
1 1 1 1 1 1 1 1
0 0 0 0 1 1 (2реш) 1 1 (3 решения)
0 1 0 1 0 1 0 1
1 1 1 0 0 0
Итак, при х1=1 - одно решение, при х1=0 - 5 решений
Для второго ( с Y) и третьего ( сZ ) ур-я - аналогично по 5 решений.
Возможные варианты сочетаний значений х1, y1,z1 :
х1 y1 z1
0 0 0 - (четвёртое уравнение исключает это сочетание)
0 0 1 5*5*1 =25 решений
0 1 0 5*1*5 =25 реш
0 1 1 5*1*1 =5
1 0 0 1*5*5=25
1 0 1 5 реш
1 1 0 5
1 1 1 1
5+5+5+25+25+25+1 = 91 < ответ
Если ответ не верный, напишите. Буду думать.
var
n, num, i : integer;
begin
write('Введите число: ');
readln(num);
write('Число повторений: ');
readln(n);
for i:=1 to n do write(num, ' ');
end.
program Second;
var
num, count, summ : integer;
begin
writeln('Вводите числа. (для выхода введите число 0)');
count:=0;
summ:=0;
repeat
readln(num);
if num<>0 then
begin
count:=count+1;
summ:=summ+num;
end;
until num=0;
writeln ('Введено ', count, ' чисел, на сумму ', summ);
end.
program Third;
var
z : integer;
s : real;
begin
z:=5;
s:=0;
repeat
s:=s+1/z;
z:=z+5;
until z=50;
writeln ('Сумма равна: ', s:7:4);
end.