В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tatianIWANOWNA
tatianIWANOWNA
27.12.2022 02:59 •  Информатика

написать программу Паскаль которая находит корни квадратного уравнения. D>0, D=0 С Else, if, then

Как на картинке , только без ошибок


написать программу Паскаль которая находит корни квадратного уравнения. D>0, D=0 С Else, if, then

Показать ответ
Ответ:
avatariyaflora
avatariyaflora
05.10.2021 19:16

Я бы написал по другому

 

Program vozvedenie_v_stepen;

var a,b:integer;

begin

writeln ('Введите число, которое будем возводить в степень');

readln (a);

writeln ('Введите число, обозначающее степень, в которую будем возводить');

readln (b);

Writeln (a,' в степени ',b,' = ',exp(b*ln(a))); 

end. 

 

Извиняюсь за неправильный ответ. Не увидел, что вам нужно с циклом. Тогда лучше так...

 

Program vozvedenie_v_stepen;
var a,b,c,d:integer;
begin
writeln ( 'Введите число, которое будем возводить в степень' );
readln (a);
c:=a;
writeln ( 'Введите число, обозначающее степень, в которую будем возводить');
readln (b);
for d:= 2 to b do
a:=a*c;
if b=0 then
writeln(1)
else
writeln (c,' в степени ',b,' = ',a);
end. 

0,0(0 оценок)
Ответ:
Виолетта2018
Виолетта2018
10.10.2021 18:23

Непонятно, что за "надписи".

Предположим, что

1. "бабушка попросила"

2. "взяла лукошко"

3. "подошла к кусту"

4. "сорвала ягоду"

5. "сварили варенье"

тогда логика задачи будет следующей

 

бабушка попросила

Если Маша согласилась тогда

      взяла лукошко

      подошла к кусту

      Если куст с ягодами Тогда

          Пока (на кусте есть ягоды) и (лукошко пустое) Цикл

                  сорвала ягоду

          КонецЦикла

      КонецЕсли

      сварили варенье

КонецЕсли

 

В принципе, если несколько кустов, нужен цикл обхода по кустам пока не наполнится лукошко.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота