Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Tikhon228
06.01.2020 19:22 •
Информатика
Написать программу, одномерный массив из 10 элементов. значения членов массива вводятся при выполнении программы. программа должна определять сумму поло-жительных членов массива. пож
Показать ответ
Ответ:
ZlataM1
03.10.2020 18:47
//Pascal ABC.NET 3.1 сборка 1256
begin
var ar:=readArrInteger(10);
writeln(ar.Where(x -> x>0).Sum);
end.
Пример ввода:
-1
2
-3
4
-5
6
-7
8
-9
0
Пример вывода:
20
0,0
(0 оценок)
Популярные вопросы: Информатика
pixxxiv
17.05.2023 03:16
Дано натуральное число х. вычислить y = x5. разрешается использовать только три операции умножения. протестировать про протестировать программу для x=-2 и x=3. составить...
veronikashows
07.12.2021 07:31
Составьте программу для возведения в n-ую степень каждого числа 10-ти элементного массива. степень запросите с клавиатуры. по окончании работы программы, на экране должен...
Ульяна1561
07.12.2021 07:31
Как решить вот эту ,вопрос такой составление значений функции y=sin x отрезке [0; 3.14] с шагом 0.1...
Новоселова1Лиза
07.12.2021 07:31
Дано трехзначное число n. проверить, будет ли сумма его цифр четным числом. кто может составьте блок схему алгоритма и программу ана алгоритмическом языке паскаль...
nikitkasorokin2
17.05.2021 03:18
Фигуры пронумерованы следующим образом: 1 — круг, 2 — квадрат, 3 — прямоугольник. в зависимости от номера фигуры запросить у пользователя необходимые данные и вычислить...
hasan095mudrec
17.05.2021 03:18
1. организовать в памяти эвм массив, состоящий из первых двадцати натуральных четных чисел. определить количество элементов, делящихся нацело на 5. 2. дан массив а(30)....
artyrik412002
17.05.2021 12:59
Создать программу распорядка дня в паскале...
EdSid
21.11.2022 11:21
Составить программу,в паскале вычисляющую стоимость покупки из нескольких тетрадок, ручек, карандашей. стоимость и кол-во вводить с клавиатуры....
andreyoy
20.01.2021 20:59
Нужно на языке PythonНапишите программу по следующему алгоритму...
nastasyasaenko
22.10.2021 09:04
Запишите значение переменной s, полученное в результате работы следующей программы. var s,k: integer; begin s := 0; for k := 7 to 12 do s := s + 11; writeln(s); end....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var ar:=readArrInteger(10);
writeln(ar.Where(x -> x>0).Sum);
end.
Пример ввода:
-1
2
-3
4
-5
6
-7
8
-9
0
Пример вывода:
20