В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vfggggggd
vfggggggd
09.11.2020 08:59 •  Информатика

***написать программу на языке паскальabc заданы массивы целых чисел x(n) и y(k). все совершенные числа из этих массивов переписать в массив z. в массиве z найти четыре наименьших элемента массива. удалить из массива z все нулевые элементы результаты вывести на экран в восьмеричной системе заранее за !

Показать ответ
Ответ:
LINKAyO
LINKAyO
16.05.2023 07:25
1.const  N=10;
type Vector = array [1..N] of integer;
var B: vector;   
     max :integer;
procedure IntVector(N: integer; var a: vector);
begin 
 for var i := 1 to N do  a[i] := random(100);
end;
procedure OutVector(N: integer; a: vector);
begin  for var i := 1 to N do  
begin      write(a[i]:5);
end;
end;
procedure Srav (a:vector; N,g:integer);
begin
g := a[1];
for var i:=1 to N do
if (g < a[i]) then g:=a[i];
writeln (g);
end;
Begin 
IntVector(N, B); 
writeln; 
OutVector(N, B ); 
writeln;  
Srav(B,N, max); 
writeln;
End.
2. const  N = 10;
type  Vector = array [1..N] of integer;
var  B: vector; 
     r,v : real; 
procedure IntVector(N: integer; var a: vector);
begin 
for var i := 1 to N do    
a[i] := random(20);
end;
procedure OutVector(N: integer; a: vector);
begin 
 for var i := 1 to N do  
begin   
write(a[i]:5); 
 end;
end;
function srednee(a: vector; N: integer): real;
begin 
for var i := 1 to N do   begin   result := (result + a[i]);  
end; 
end;
function kolvo(a: vector; g: real): real;
begin 
for var i := 1 to N do
   if (a[i] < (srednee(a, N)/10)) then result := result + 1;
end;
begin 
IntVector(N, B);  writeln; 
OutVector(N, B ); 
writeln; 
writeln ((srednee(B, N)/10):5:3);   r := kolvo(B, v); 
writeln(r);
end.
0,0(0 оценок)
Ответ:
niceglotatel
niceglotatel
28.04.2023 04:00
Var a,d,count,i:integer;
function CountDay(a:integer):integer;
begin
if (a>=1) then countday:=31;
if (a>=2) then countday:=28;
if (a>=3) then countday:=31;
if (a>=4) then countday:=30;
if (a>=5) then countday:=31;
if (a>=6) then countday:=30;
if (a>=7) then countday:=31;
if (a>=8) then countday:=31;
if (a>=9) then countday:=30;
if (a>=10) then countday:=31;
if (a>=11) then countday:=30;
if (a>=12) then countday:=31;
end;
begin
count:=0;
write('Введите День: ');
readln(d);
write('Введите Месяц: ');
readln(a);
if (a<=0)or(a>12)or(d<=0)or(d>countday(a)) then
writeln('Ошшибка в данных! ')
else
begin
for i:=a to 12 do
count:=count+countday(i);
count:=count-d;
writeln('До нового года осталось ',count,' дней');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота