В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
astashkin222
astashkin222
25.05.2023 07:40 •  Информатика

Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетные числа и выводит на экран их кол-во.

Показать ответ
Ответ:
diana02lili
diana02lili
13.10.2020 05:02

program answer;

uses CRT;

Var  

a: array [1..30] of integer;

i: integer; n:integer;

begin

clrscr;

for i:=1 to 30 do begin

a[i]:= random(100);

writeln (a[i]);

end;

Writeln ('chetnie chisla s massiva: ');

   for i:=1 to 30 do

       begin

       if ((a[i]) mod 2 = 0) then writeln (a[i])

       end;

end.

0,0(0 оценок)
Ответ:
Brainsetup
Brainsetup
13.10.2020 05:02

// PascalABC.NET

begin

 var a := ArrRandom(30, -99, 99);

 a.Println.Count(p -> p.IsOdd).Print

end.


Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетны
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота