В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу, , . вид экрана: введите числа. для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67

Показать ответ
Ответ:
Фприт
Фприт
11.06.2020 03:29

 

 

 

В задании не сказанно что числа целые  поэтому тип c: real;

 

 Program SumAndAvg;  

 Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat

read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;

until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота