В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
topcekstrimer
topcekstrimer
08.02.2020 09:40 •  Информатика

Написать программу на pascal abc. дано предложение. вывести строку в обратном порядке. вывести столбиком все его буквы "и", стоящие на четных местах.

Показать ответ
Ответ:
максим1676
максим1676
06.07.2020 21:16
Var
  str : string;
  i, count : integer;
begin
  {часть 1 - обратный порядок}
  write('Введите строку: ');
  readln(str);
  write('Результат: ');
  for i := length(str) downto 1 do
    write(str[i]);
  {часть 2 - считаем "и"}
  count := 0;
  for i := 1 to length(str) do
    if (str[i] = 'и') and (i mod 2 = 0) then
      count := count + 1;
  writeln;           {переходим на следующую строку}
  for i := 1 to count do
    writeln('и');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота