В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sudibor
sudibor
03.03.2020 22:33 •  Информатика

Написать программу, которая вычисляет среднее арифметическое последовательности дробных чисел, вводимых с клавиатуры. после того, как будет введено последнее число, программа должна вывести разность между минимальным и максимальным числом последовательности. количество чисел должно задаваться во время работы программы. паскаль

Показать ответ
Ответ:
Amelka06
Amelka06
19.06.2020 07:10

program raf105;

var

 n,i: integer;

 a,sum,sari,min,max: real;

begin

 write('Введите количество чисел: ');

 readln(n);

 writeln('Воодите числа по очереди');

 min:= 10000;

 max:= -10000;

 for i:=1 to n do

 begin

   readln(a);

   sum:= sum+a;

   if a > max

     then max:= a;

   if a < min

     then min:= a;

 end;

 sari:= sum/n;

 writeln('Среднее арифметическое: ',sari);

 writeln('Разность максимального и минимального числа: ',max-min);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота