В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AliskaLao16
AliskaLao16
11.02.2023 09:36 •  Информатика

Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры, находит количество элементов больших заданного числа.

Показать ответ
Ответ:
Решение на Си:

#include <stdio.h>

int main() {

  int array[100]; // массив элементов
  int n, k, count = 0; // вс числа

  printf("Введите число для сравнения:");
  scanf("%d", &k); // запоминаем число для сравнения

  printf("\nВведите количество элементов:");
  scanf("%d", &n); // запоминаем количество элементов в массиве

  printf("\nВведите %d элементов: ", n);
  for (int i = 0; i < n; i++) {
     scanf("%d", &array[i]); // считываем массив

    if (array[i] > k) { // если число в массиве строго (!) больше нужного 
     count++; // то увеличиваем счётчик 
    }
  }

  printf("\n%d элементов больше, чем %d.", count, k); // выводим результат
 
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота