В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
saididag
saididag
15.03.2020 02:54 •  Информатика

Написать программу, которая в файл «z3.dat» записывает 20 первых элементов последовательности an = 3n – 15.
program n3;
var T: text; n, a: integer;
begin
assign (__, );
rewrite (T);
for n:=1 to ___ do
begin
a := 3*n – 15;
Write (___, a);
end;
close (___);
end.

Показать ответ
Ответ:
Potap4uk
Potap4uk
31.05.2022 20:53

Для формирования сводного отчета по документооборотам выполните действия:

1. Выберите в главном меню «Действия – Сформировать отчет».

Откроется окно «Формирование отчета».

2. Укажите период, за который необходимо сформировать отчет по документооборотам. Для этого воспользуйтесь встроенным календарем или ссылками:

за все время - автоматически проставляется период с начала использования программы по текущую дату.

за месяц - автоматически проставляется период за месяц от текущей даты.

за неделю - автоматически проставляется период за дней от текущей даты.

3. Выберите документообороты, которые необходимо отобразить в сводном отчете при чекбоксов.

4. Укажите при необходимости для каждого направления документооборота дополнительные параметры, нажав на значок .

5. Развернется форма <Название направления документооборота> , например «Налоговая служба».

6. После того как все необходимые параметры отчета заполнены, нужно нажать на кнопку «Сформировать отчет». Начнется процесс формирования отчета, по окончании которого откроется окно просмотра отчета.

0,0(0 оценок)
Ответ:
Ника5324
Ника5324
14.04.2023 01:34
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота