В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
denkarlay
denkarlay
25.03.2020 10:10 •  Информатика

Написать программу которая реализует алгоритм разложения числа на простые множители(paskal abc).

Показать ответ
Ответ:
Daeshka88
Daeshka88
16.09.2021 17:21
Uses Crt;
Var a,b,i,tek,sum10,sum3:integer;
Procedure TroichSS (te:integer; var sum3:integer);
var m:array[1..10]of integer;
    k,j,su3:integer;
begin
    write(te:4);
    repeat
        inc(k); m[k]:=te mod 3; te:=te div 3;
    until te<3;
    inc(k); m[k]:=te mod 3;
    for j:=k downto 1 do
        begin su3:=su3+m[j]; write(m[j]:3) end;
    write(' su3=',su3);
    sum3:=su3; su3:=0; k:=0;
end;
Procedure DesiatSS (te:integer; var sum10:integer);
var m:array[1..10]of integer;
    k,j,su10:integer;
begin
    write(te:4);
    repeat
        inc(k); m[k]:=te mod 10; te:=te div 10;
    until te<10;
    inc(k); m[k]:=te mod 10;
    for j:=k downto 1 do
        begin su10:=su10+m[j]; write(m[j]:3); end;
    writeln(' su10=',su10);
    sum10:=su10; su10:=0; k:=0;
end;
Begin
//Задание интервала [a; b]
    a:=1; b:=1000;
    writeln('Интервале [a; b]',a:4,b:4);
//Сумма цифр троичных и десятичных чисел
    for i:=a to b do
    begin
        TroichSS(i,sum3); DesiatSS(i,sum10);
        if sum3=sum10 then
            begin writeln('Э в р и к а!'); delay(5000); end;
    end;
    writeln('К о н е ц.');
End.

ответ: 39
0,0(0 оценок)
Ответ:
ferid9098
ferid9098
20.08.2021 05:37

 На одну чашу весов поместим две монеты, на другую – монету и гирю. Если весы уравновесятся, то фальшивая монета та, что осталась. За второе взвешивание определим, легче она или тяжелее любой из настоящих монет (или гири). Если же весы не уравновесятся, то наверняка можно утверждать, что настоящей является отложенная монета. Предположим, что перевесила чаша, на которой находятся две монеты. Сравним эти монеты при втором взвешивании. Если весы уравновесятся, то фальшивая монета легче, и она находится рядом с гирей. В противном случае фальшивой окажется более тяжелая из двух сравниваемых монет.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота