В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sofizlatich
sofizlatich
04.11.2022 13:46 •  Информатика

Программирование на Java


Программирование на Java

Показать ответ
Ответ:
BOSS653
BOSS653
05.05.2020 09:58
  1. 
Составить структурную схему алгоритма и программу на языке Qbasic для вычисления f:
a=-1
b=4
f1(x) x<a
f2(x) a<=x<b
f3(x) x>=b
f1(x)=(a-x)/(2+3x^2) ; f2(x)=(a+b)x-x^2-ab; f3(x)=(b-x)/(5+x^2)
2. 
Составить структурную схему алгоритма и программу на языке Qbasic
m=17
задание на программирование: составить программу вычисления m значений переменной Xk по рекурентной формуле 
Xk=(далее выражение под корнем)2*(Xk-1)^2-7(Xk-1)+9
для k=1,2,3,...,m
3.
Составить структурную схему алгоритма и программу на языке Qbasic 
a=4
b=12
Задание на программирование:
диффиренциал от a до b x^2*bx
4.
Составить блок схему алгоритма и программу на языке Qbasic при решении диффиренциального уравнения методом Эйлера:
(dy/dt)*2y+t=0
при y0=25; t0=0; tk=30; n=30
5.
Составить программу для вычисления основных статистических показателей выработки 2^x попарносвязанный значени x и y. РАсчитать основные статистические показатели для выработки:
x y
23 8
21 9
20 10
7 18
2 1
13 6  
0,0(0 оценок)
Ответ:
masha3323
masha3323
15.08.2022 01:35

 

uses crt;
var a:array[1..11] of integer;
i,j,s,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to 10 do begin
a[i]:=random(5);
write(a[i]:4);
end;
s:=1; k:=0;
for i:=1 to 10 do begin
if a[i]=a[i+1] then s:=s+1;
if a[i]<>a[i+1] then begin if k<s then k:=s; s:=1; end;
end;
writeln;
 writeln('Наибольшая последовательность одинаковых элементов: ',k);write(k);
end.

 

 Массив состоит из 10 чисел (в описании максимум чисел должен быть на 1 больше, чем по факту, поэтому там 11). Числа в массиве задаются случайно в пределах от нуля до 5 (не включая 5).

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота