В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
eliza1404
eliza1404
12.07.2022 03:26 •  Информатика

Написать программу, которая принимает от пользователя количество числовых значений (указывает сам пользователь) для переменной и считает количество введенных трехзначных чисел, если учитывать, что вводиться могут числа в диапазоне от 0 до 10000 (по умолчанию).

Показать ответ
Ответ:
alina06122
alina06122
24.09.2020 18:58
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,n,n3:integer;
begin
    writeln('Введите количество чисел');readln(n);
    for i:=1 to n do begin
      readln(a);
      if (a>99) and (a<1000) then n3:=n3+1;
    end;
    writeln('Всего трехзначных чисел :',n3);
end.

Тестовое решение:
Введите количество чисел
5
22
123
4
435
12
Всего трехзначных чисел :2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота