В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Cancanich
Cancanich
02.04.2021 19:28 •  Информатика

Надо написать программу определяющую характеристику произвольного числа введённого через клавиатуру.

Показать ответ
Ответ:
aleks1yus
aleks1yus
25.05.2020 22:53

var a:integer;

begin

write('Введите произвольное число'); readln(а);

if a = 0 then begin

writeln ('Введен нуль');

exit;

end;

if а > 0 then writeln ('Число положительное');

else writeln ('Число отрицательное');

if a mod 2 = 0 then writeln('Число четное');

if a mod 3 = 0 then writeln('Число кратно 3');

if a mod 5 = 0 then writeln('Число кратно 5');

if a mod 7 = 0 then writeln('Число кратно 7');

if a mod 9 = 0 then writeln('Число кратно 9');

if a mod 10 = 0 then writeln('Число кратно 10');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота