В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yanashowsouany
yanashowsouany
15.10.2022 18:39 •  Информатика

На вход программе подается одна строка – числа, разделенные пробелами. Считайте эти числа в список. Найдите для него максимальный элемент, минимальный элемент и сумму элементов. На вход программе подается одна строка – числа, разделенные пробелами. Считайте эти числа в список. Отсортируйте элементы списка по возрастанию и по убыванию. Выведите полученные списки на экран.

На вход программе подается одна строка, состоящая из слов на английском языке, разделенных пробелами. Создайте список из слов и выведите его элементы по одному в строке.

На вход программе в первой строке подается число n – количество слов в списке, затем n строк по 1 слову в каждой. Выведите элементы списка в одну строку, разделяя их запятыми.

Показать ответ
Ответ:
Серёжа331
Серёжа331
05.05.2022 05:49
Const n=12;
var
  a:array[1..n] of integer;
  i,j,t:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(51)-25;
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]>a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln
end.

Пример:
Исходный массив:
-6 -11 -1 -24 -15 23 14 -13 -5 3 17 -21
Отсортированный массив:
-24 -21 -15 -13 -11 -6 -5 -1 3 14 17 23
0,0(0 оценок)
Ответ:
ivanpanyushkin1
ivanpanyushkin1
23.02.2023 06:52
1.  Словарь в компьютере или другом электронном устройстве.
2. Если переводить текст например с ангийского то некоторые слова надо переставлять и это иногда затрудняет, но всё же можно разобраться.
3. Словарь переводит отдельные слова в именительном падеже, а система перевода переводит слова, если встречаются выражения - переводит их не отдельными словами, а целиком. Кроме того, система перевода выставляет нужные падежи, правильно выставляет слова и старается подобрать набор слов наиболее литературно, но не всегда удачно.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота