В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Jdhcb
Jdhcb
05.05.2020 13:45 •  Информатика

Python 3 help написать 3 программы 1. известно, что 1 дюйм равен 2.54 см. разработать приложение, переводящие дюймы в сантиметры и наоборот. (перевод оформить в функции) диалог с пользователем реализовать через систему меню. 2. написать программу, которая вычисляет сумму и произведение всех положительных четных чисел из введенных шести. 3.напишите функцию procent, которая возвращает процент от полученного в качестве аргумента числа.

Показать ответ
Ответ:
poliaaaaaa
poliaaaaaa
17.08.2020 07:23

def translation_of_lengths(n, m):

   inch = 2.54

   if m == 'duim':

       print("{} inch = {}cm ".format(n, (n * inch)))

   if m == 'cm':

       print("{} cm = {} inch ".format(n, (round(n / inch, 2

translation_of_lengths(5, 'duim')

translation_of_lengths(120, 'cm')

def even_numbers(s):

   s_mas = s.split()

   if len(s_mas) != 6:

       print("\tYou have entered not 6 numbers!")

       print(s_mas)

   else:

       x = sum(int(i) for i in s_mas if int(i) >= 0 if int(i) % 2 == 0)

       print("The sum of even numbers {}".format(x))

a = input("Numbers: ")

even_numbers(a)

def procent(x, y):

   print('{}% from the number {} = {}'.format(x, y, (x / 100) * y))

procent(55, 120)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота