В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
misskamii
misskamii
15.11.2021 04:20 •  Информатика

На уроке мы составили программу для решения задачи о стоимости покупки в магазине:
В магазине купили перчатки, портфель, галстук. Составить программу на языке Паскаль, которая будет считать сумму всей покупки и выводить на экране фразу «Покупка стоит … рублей».
Задание:
Измените данную программу так, чтобы она считала остаток денег после покупки.
Подсказка: для решения задачи необходимы еще две переменных: 1 – для ввода количества всех денег у покупателя (назовем ее r), 2 – для подсчета остатка денег у покупателя после оплаты покупки (назовем ее ostatok).
В конце программы должна выводиться фраза:
writeln('у вас осталось ',ostatok,'руб');

Показать ответ
Ответ:
Anna567894
Anna567894
30.04.2022 02:50

1) Pygame - Библиотека Python, предназначенная для создания игр и мультимедийных приложений. Базируется на библиотеке для мультимедийных приложений SDL. Написана на языке С

2) Для использования библиотеки PyGame нужно установить её с менеджера пакетов Python и импортировать в свой проект

cmd: pip install pygame

project.py: import pygame ИЛИ from pygame import *

3) Библиотека PyGame содержит класс pygame.Color, отвечающий за работу с цветами

Так же класс pygame.Surface имеет некоторые методы, позволяющие изменять его цвет.

Объяснение:

Более подробную информацию вы можете найти на официальной странице Pygame.

0,0(0 оценок)
Ответ:
tiomashash
tiomashash
27.11.2021 11:53

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота