В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

На с++ через asembler. массив из 10 беззнаковых слов. Инвертировать биты старших байтов всех элементовмассива. Найти сумму парных элементов

Показать ответ
Ответ:
hadizat886
hadizat886
05.01.2022 12:41

Объяснение:

var

 x, a, b:integer;

 ras_x_a, ras_x_b, ras_a_b:integer;

 ras_min:integer;

begin

 x:=5;

 

 a:=1;

 b:=8;

 

 ras_x_a:=abs(x-a);

 ras_x_b:=abs(x-b);

 ras_a_b:=abs(a-b);

 

 if ((ras_x_a <=ras_x_b) and (ras_x_a <=ras_a_b)) then

   ras_min:=ras_x_a

 else

   if ((ras_x_b <=ras_x_a) and (ras_x_b <=ras_a_b)) then

   ras_min:=ras_x_b

   else

     if ((ras_a_b <=ras_x_a) and (ras_a_b <=ras_x_b)) then

     ras_min:=ras_a_b;

     

 writeln(ras_min);

 

end.

0,0(0 оценок)
Ответ:
Iskrmsndrxjdjjsd
Iskrmsndrxjdjjsd
05.12.2021 04:19

ответ НА ПИТОНЕ ИЛИ С++

Задача 4: Американские горки

Аттракцион «Американские горки» представляет собой рельсовый трек, размещённый на опорах. Известна высота каждой опоры. Для рекламы аттракциона необходимо выделить один из его фрагментов (несколько подряд идущих опор с рельсовым треком) световой подсветкой. При этом необходимо выделить такой фрагмент трека, на котором была бы «горка» то есть на выделенном участке трека была бы точка, которая находилась бы строго выше начала и строго выше конца выделенного фрагмента трека.

Владелец аттракциона для экономии хочет найти подходящий участок минимальной длины, удовлетворяющий условию наличию «горки» на этом участке.

Входные данные

Первая строка входных данных содержит число N – количество опор аттракциона. Следующие N строк содержат информацию о высотах опор при движении от начала к концу аттракциона. Все числа натуральные, не превосходящие 105.

Выходные данные

Программа должна вывести два числа – номер первой и последней подходящей опоры. Опоры нумеруются числами от 1 до N. Если фрагмента, удовлетворяющего условиям, не существует, программа должна вывести одно число 0. Если подходящих ответов несколько, нужно вывести любой из них.

Система оценивания

Решение, правильно работающее только для случаев, когда все входные числа не превосходят 100, будет оцениваться в 40 баллов.

В 100 баллов будет оцениваться решение, правильно работающее, когда все числа не превосходят 105.

Примеры

Ввод Вывод Пояснение

7

18

10

15

20

20

10

3

3 6

Дано 7 опор с высотами 18, 10, 15, 20, 20, 10, 3. Самый короткий участок, содержащий «горку» – это 15, 20, 20, 10. Он начинается опорой номер 3 и заканчивается опорой номер 6.

3

9

8

5

0

Высоты опор убываю

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота