В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ELOGE
ELOGE
16.05.2020 05:50 •  Информатика

На паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: нод(а,в,с)=нод(нод(а,в),с)

Показать ответ
Ответ:
masha6610
masha6610
15.06.2020 02:50

function NOD (x,y:longint):longint;
begin
if x=0 then NOD:=y
else
if y=0 then NOD:=x
else
if x>y then NOD:=NOD(x mod y,y)
else
NOD:=NOD(x,y mod x);
end;

var
a,b,c:longint;
begin
read(a,b,c);
writeln('NOD (',a,',',b,',',c,') = ',NOD(NOD(a,b),c));
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота