На PascalABC написать программу: 1. Дано двузначное число а. Верно ли, что сумма цифр этого числа кратна 7 и первая цифра чётна.
2. Дано трёхзначное число а. Верно ли, что все цифры этого числа больше 3.
3. Дано пятизначное число а. Верно ли, что сумма второй, третьей, четвёртой цифр кратна сумме первой и пятой цифр.
1) var a,b: integer ;
begin
readln(a);
b:=(a mod 10)+(a div 10);
if ((b mod 7=0) and ((a div 10) mod 2 =0)) then writeln ('верно') else writeln ('не верно')
end.
2)var a,b,i: integer;
begin
readln(a);
for i:=1 to 3 do
if a mod 10 > 3 then begin b:=b+1; a:=a div 10; end;
if b=3 then writeln ('верно') else writeln ('не верно')
end.
3)var a,b,c,d,i: integer;
begin
readln (a);
b:= b+a mod 10;
d:= a div 10000;
b12:=b+d mod 10;
a:=a div 10;
for i:=1 to 3 do begin c:=c+a mod 10; a:=a div 10 end;
if c mod b =0 then writeln ('верно') else writeln ('не верно') ;
end.