В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
toshaantoshai
toshaantoshai
10.02.2021 05:08 •  Информатика

Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (1≤N≤1000).

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

Показать ответ
Ответ:
danilru940Vova
danilru940Vova
12.01.2021 13:36

var sum,i,N:integer; t,t1:text;

begin

 assign (t, 'input.txt'); reset(t);

 assign (t1, 'output.txt'); rewrite(t1);

read(t,N);

sum:=0;

for i:=1 to N do

 if N mod i = 0 then sum:= sum+i;

write(t1,sum);

close(t1)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота