В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruslanantosyuk1
ruslanantosyuk1
08.11.2020 02:43 •  Информатика

Методика выполнения работы 1. программа имеет линейную структуру в соответствии с алгоритмом на рис. 5.2. s1 – блок ввода исходных данёных a, b, c. s2 – блоки расчета полупериметра треугольника p и площади s. s3 – блок вывода результата: площадь s. введите программу решения этой (см. пп. 1-3, лабораторная работа № 1). program geron; uses crt; var a,b,c,p,s: real; begin clrscr; {ввод исходных данных} writeln(‘введите значения сторон треугольника a,b,c’); readln(a,b,c); {расчет полупериметра и площади треугольника} p: = 0.5*(a+b+c); s: =sqrt(p*(p-a)*(p-b)*(p-c)); {вывод результата расчета} writeln(‘площадь треугольника = ’, s: 5: 3) end. 2. откомпилируйте программу и исправьте возможные ошибки. затем запустите программу на счет (см. пп. 4-5, лабораторная работа № 1). 3. проведите тестовый расчет, чтобы убедиться в правильности работы программы. введите значения сторон: a=1, b=1, c=1. должен получиться результат s=0.433. 4. проведите серию расчетов для различных значений сторон треугольника. 5. если значения сторон являются константами (например, все равны 1), то в данную программу можно ввести следующие изменения:  перед разделом var надо добавить раздел констант – const a=1; b=1; c=1;  из раздела var убрать a,b,c – var p,s: real;  убрать ввод исходных данных – удалить операторы writeln(‘введите…’); readln(a,b,c); 6. сделайте указанные исправления и повторите пп. 1-3 данной работы. для самостоятельной работы составить программу на языке паскаль для нахождения значения выражения. константы a, b, c вводятся с клавиатуры. сложные аргументы функций вычислять отдельно, tan(x) вычислять как sin(x)/cos(x), ctan(x) → cos(x)/sin(x), xy → exp(y*ln(

Показать ответ
Ответ:
Maga052005
Maga052005
05.04.2023 00:09

HTTPS - это защищенный протокол передачи гипертекста (Hyper Text Transfer Protocol Secure). Это продвинутая и безопасная версия HTTP. Для коммуникации данных используется 443-ий порт. Данный протокол позволяет обеспечить безопасность транзакций путем шифрования всего трафика с SSL. Это комбинация протокола SSL/TLS и HTTP. Обеспечивает зашифрованную и безопасную идентификацию сетевого сервера.

HTTP расшифровывается как Hyper Text Transfer Protocol - Протокол Передачи Гипертекста. HTTP предлагает набор правил и стандартов, которые регулируют передачи любой информации во Всемирной паутине. HTTP предоставляет стандартные правила для взаимодействия веб-браузеров и серверов. По умолчанию данный протокол использует 80-ый порт.

HTTP - это сетевой протокол прикладного уровня, созданный поверх TCP. HTTP использует структурированный текст

0,0(0 оценок)
Ответ:
dalakovadg
dalakovadg
07.12.2022 18:00

на Free Pascal

Объяснение:

var

 a : integer;

 n, i, big, nc, ncount  : integer;

begin

 writeln('Введите количество чисел :');

 readln(n);

 big := 0;

 nc := 0;

 ncount := 0;

 for i := 1 to n do begin

   writeln('Введите ', i, ' число:');

   readln(a);

   if a>20 then

     big := big + a;

   if (a mod 2) <> 0 then begin

     nc := nc + a;

     inc(ncount);

   end;

  end;

 writeln('Сумма чисел > 20 = ', big);

 writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота