В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vika32ytr4
Vika32ytr4
27.10.2022 21:33 •  Информатика

Меня зовут Иван. Составьте программу, которая печатает в первой строке одну первую букву Вашего имени, во второй – две первые буквы, в третьей -3, ..., в строке с номером к - к первых букв.

Печать строки оформить через процедуру. Число строк вводить с клавиатуры.

Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию.

После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран)...(заполнить) ');

Показать ответ
Ответ:
нуразмед
нуразмед
08.12.2021 11:11
1) 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 program program1; var s,subs:string;c:char;isOneNumber:boolean;p:byte;n,err:integer; begin writeln('‚Введите фразу'); readln(s); c:=s[1]; isOneNumber:=false; p:=pos(' ',s); while p<>0 do  begin  if p=1 then   begin   s:=copy(s,2,length(s));   p:=pos(' ',s);   continue;   end;  subs:=copy(s,1,p-1);  s:=copy(s,p+1,length(s));  p:=pos(' ',s);  val(subs,n,err);  if err<>0 then continue;  if (n=0) or (n>9) then continue;  isOneNumber:=true;  break;  end; if isOneNumber then writeln('‚ Есть числа, сосотоящие из одной цифры') else writeln('‚Нет чисел, состоящих из одной цифры'); end.
0,0(0 оценок)
Ответ:
DDddd532222
DDddd532222
29.03.2020 02:48
Если на паскале сойдет, лови:
И так, нам надо создать массив чисел и заполнять его числами вводимых с клавиатуры. Значит мы должны использовать цикл for для ввода чисел, и так же для увеличения каждого числа на 8.
...
Вот код:
const n = 3; //Сколько чисел вводить
begin
var numbers: array [1..n] of integer; //Объявляем массив чисел
for var i := 1 to n do readln(numbers[i]); //Считываем числа n раз
for var i := 1 to n do numbers[i] := numbers[i] + 8; //Увеличиваем каждое число на 8
writeln(numbers.JoinIntoString(', ')); //Выводим числа
end.
...
Примеры:
Ввод: 1, 2, 3
Вывод: 9, 10, 11

Ввод: 0, 5, 7
Вывод: 8, 13, 15
...
Если не сложно нажми " " ;)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота