Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
sofusavihc1289
05.05.2020 00:12 •
Информатика
В"кумир". 8 класс 1) ввести число. если оно больше 10, разделить его на 2, если меньше или равно 10, то умножить на 5. 2) ввести два числа . если их сумма больше 100, то сумму уменьшить в 2 раза, в противном случае увеличить в 2 раза
Показать ответ
Ответ:
craisler320
30.04.2020 14:47
№1
алг
нач
вещ a
ввод a
если a>10 то a:=a/2 иначе a:=a*5 все
вывод a
кон
№2
алг
нач
вещ a,b,sum
ввод a,b
sum:=a+b
если sum>100 то sum:=sum/2 иначе sum:=sum*2 все
вывод sum
кон
0,0
(0 оценок)
Ответ:
Sykaper
30.04.2020 14:47
1)var
n:real;
begin
readln(n);
if n>10 then
n:=n/2
else
n:=n*5;
writeln(n);
end.
2) var
a, b: integer;
begin
writeln('Введите два числа: ');
read(a, b);
if a + b > 100 then writeln((a + b) / 2)
else writeln((a + b) * 2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vorobeva85ramon
06.10.2021 18:43
Информационное сообщение объёмом 375 байтов состоит из 500 символов. Каков информационный вес каждого символа этого сообщения? Какова мощность алфавита, с которого было...
Ксюша00111
06.04.2022 21:34
Пользователь вводит текст с клавиатуры со скоростью 90 знаков в минуту. какое количество информации будет содержать текст который он набирал 15 минут?...
72737
06.04.2022 21:34
Составьте программу которая выводит на экран пример на умножение двух целых чисел,запрашивает ответ пользователя.проверяет его и выводит соответсвующиеся сообщения : правильно!...
Veronika234629
06.04.2022 21:34
Напишите сказку про компьютер из 4-6 предложений....
DOSYMZHAN1
22.10.2021 20:15
решить задачу вот эту да да да...
sofija97
10.03.2021 21:23
Решите логическое уравнение (x1∨x2)∧((x3∧x4)→(x1∧x2))=0 . Замечание: Знак «Λ» означает логическое «и»; x¯ означает логическое отрицание x; знак «V» означает логическое...
dashakid1
10.07.2021 05:19
Умоляю Найдите наибольшее натуральное число, принадлежащее отрезку [174457;174505] имеющее ровно два различных натуральных делителя,не считая единицы и самого числа...
yaya4
04.10.2020 04:22
In the south of england, near surrey, elspeth beard, the famous architect has got a very unusual house. it s a water tower, 130 ft* tall. the house is 100 years old. the...
aldynsaioorzhak1
11.04.2021 06:18
Твір на тему я тополя за нашим вікном...
Акмарал252887
11.04.2021 06:18
Почему пугачев терпеливо слушает реестр савельича и что его возмутило?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
алг
нач
вещ a
ввод a
если a>10 то a:=a/2 иначе a:=a*5 все
вывод a
кон
№2
алг
нач
вещ a,b,sum
ввод a,b
sum:=a+b
если sum>100 то sum:=sum/2 иначе sum:=sum*2 все
вывод sum
кон
n:real;
begin
readln(n);
if n>10 then
n:=n/2
else
n:=n*5;
writeln(n);
end.
2) var
a, b: integer;
begin
writeln('Введите два числа: ');
read(a, b);
if a + b > 100 then writeln((a + b) / 2)
else writeln((a + b) * 2);
end.