В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tushenka88
tushenka88
27.09.2020 01:59 •  Информатика

Меньше среднего.с++.8 класс Дан массив A из N элементов. Требуется найти и вывести количество элементов,
значение которых меньше среднего арифметического значения элементов массива.
Input
Со стандартного устройства ввода в первой строке вводится целое число
N (1 <= N <=1000) — количество элементов массива. Во второй строке через пробел
вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000).
Output
Требуется вывести целое число - количество искомых элементов. Выводить в конце
строки пробел не нужно.
Sample Input
5
2 4 6 10 8
Sample Output
2
Примечание
Среднеe арифметическое значение элементов массива =
(Сумма значений всех элементов массива) / (Количество элементов в массиве).
В примере среднеe арифметическое значение = (2 + 4 + 6 + 10 + 8) / 5 = 6.

Показать ответ
Ответ:
sab1na666
sab1na666
27.08.2021 15:05

Здесь А - массив, N - количество чисел в массиве, sum - сумма элементов массива, count - количество искомых элементов, sum * 1.0 / N - это и есть среднее арифметическое, причем если здесь не умножать на 1.0, то результат будет округлен и программа будет уже работать неправильно, а если умножать, то все хорошо, потому что sum * 1.0 / N становится вещественным числом

Объяснение:

Здесь можно использовать динамику(чтобы не занимать место в памяти статическим массивом):

#include <iostream>

using namespace std;

int main()

{

int N, sum=0, count=0;

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++) {

 cin >> A[i];

 sum += A[i];

}

for (int i = 0; i < N; i++) if (A[i] < (sum * 1.0 / N)) count++;

cout << count;

       delete[] A;

}

Но если динамика еще не изучена, то:

#include <iostream>

using namespace std;

int main()

{

int N, sum=0, count=0, A[1000];

cin >> N;

for (int i = 0; i < N; i++) {

 cin >> A[i];

 sum += A[i];

}

for (int i = 0; i < N; i++) if (A[i] < (sum * 1.0 / N)) count++;

cout << count;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота