В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
turebekrasul
turebekrasul
15.09.2021 07:22 •  Информатика

Максимум .
нужно составить программу на паскале (ниже само ).

если хотя бы два числа из трех введенных чисел положительны, то
уменьшить каждое нечетное число на 1, иначе – найти сумму всех
чисел.

Показать ответ
Ответ:
olgailinsk
olgailinsk
07.10.2020 20:34

var a,b,c,kol:integer;

 begin

   readln(a,b,c);

if a>0 then inc(kol);

if b>0 then inc(kol);

if c>0 then inc(kol);

if kol>=2 then

                      begin

                        if a mod 2=1 then dec(a);

                        if b mod 2=1 then dec(b);

                        if c mod 2=1 then dec(c);

                      end

  else writeln(a+b+c);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота