Контрольная работа № 3
НАЧАЛО ПРОГРАММИРОВАНИЯ
1. Определите значение переменной c после выполнения следующей программы:
var a, b, c: integer;
begin
a:= 10;
b:= 30;
a:= a + b * 3;
if a > b then c:= a - b else c:= b - a;
writeln (c);
end.
2. Запишите значение переменной s, полученное в результате работы программы:
var s, k: integer;
begin
s := 0;
for k := 1 to 7 do
s := s + 6;
writeln (s);
end.
3. Дана программа:
var s,t: integer;
begin
readln(s);
readln(t);
if (s > =10) or (t > 10)
then writeln ("ДА")
else writeln ("НЕТ")
end.
Было проведено 8 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).
Сколько было запусков, при которых программа напечатала «ДА»?
4. Составьте программу нахождения суммы первых 20 натуральных чисел.
1) Начало
2) Ввод массива сопротивлений R(n), упорядоченного по возрастанию
3) Ввод нужного сопротивления R0.
4) Флаг признака "Сопротивление найдено" F = 0
5) Если R0 < R(1), то
5.1) Вывод R(1), номера 1 и сообщения "Сопротивление слишком мало, на складе отсутствует"
5.2) Флаг признака "Сопротивление найдено" F = 1
5.3) Конец Если
6) Если R0 > R(n), то
6.1) Вывод R(n), номера n и сообщения "Сопротивление слишком большое, на складе отсутствует"
6.2) Флаг признака "Сопротивление найдено" F = 1
6.3) Конец Если
7) Если R0 >= R(1) и R0 <= R(n), то
7.1) Если R0 = R(1), то
7.1.1) Вывод R(1) и номера 1
7.1.2) Флаг признака "Сопротивление найдено" F = 1
7.1.3) Конец Если
7.2) Если Флаг признака F = 1, то Конец программы
7.3) Цикл по i от 2 до n
7.3.1) Если R0 = R(i), то Вывод R(i) и номера i
7.3.2) Иначе, Если (R0 > R(i-1)) и (R0 < R(i)), то
Вывод сопротивлений R(i-1) и R(i) и номеров (i-1) и i
7.3.3) Конец Если
7.4) Конец Цикла по i
8) Конец программы
2)
160 кбайт * 1024 байт к байт * 8 бит в байт = 1 310 720 бит
1280 пикс * 960 пикс = 1 310 720 бит / 1 228 800 пикселей = 1,06 ~1 бит на пиксель (меньше бита быть не может).
2^1 = 2-ух цветовая палитра (чёрно-белая) или одно-битовая палитра.
а остаток на всякий ховно пойдет типо формата или сжатия или выделили лишнее (запас или просчёт в большую сторону).
3)
40 мегабайт * 1024 раз * 1024 раз * 8 раз = 335 544 320 бит
30 мегабайт * 1024 раз * 1024 раз * 8 раз = 251 658 240 бит
4 минуты * 60 сек минута = 240 сек
16 кГц * 1000 = 16000 Гц
24 бит на один Гц * 16000 Гц за один сек * 2 стерео * 240 сек = 184 320 000 бит вес музыка.wav, качество PCM
16 бит * 16000 Гц за сек * 2 канала * 240 сек = 122 880 000 бит вес файл
24 * 32000 * 2 стерео канала * 240 = 368 640 000 бит
16 * 32000 * 2 канала стерео (в кажд канале будет 16 * 32000) * 240 = 245760000 бит
последний 4) влезет и ещё место останется, точность до 10 мегабайт это 40 + или - 10.