В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vladosik1885
vladosik1885
22.10.2022 20:19 •  Информатика

Используя цикл while, напишите программу, вычисляющую сумму квадратов чисел от 1 до введённого целого числа

Показать ответ
Ответ:
Olgarezkova
Olgarezkova
21.08.2020 00:00

import java.util.Scanner;

public class test {

   public static int calculate(int n, int m){

       int answer = 0;

       for(int i = n; i<=m;i++){

           answer += i;

       }

       return answer;

   }

   public static void main(String[] args) {

       Scanner in = new Scanner(System.in);

       int n,m;

       System.out.print("Введите n: ");

       n=in.nextInt();

       System.out.print("Введите m: ");

       m=in.nextInt();

       int answer = calculate(n,m);

       System.out.print("ответ: " + answer);

   }

}


Сначала мы вносим в переменные типа int значения n и m, после этого подаём их в качестве аргументов в метод calculate.

После этого в методе calculate объявляем переменную int answer, в которую будем записывать ответ.  Потом начинается цикл for, в каждой итерации которого будет происходить сложение. Изначально i = n и с каждой итерацией цикла будет увеличиваться на один вплоть пока не достигнет значения m, тогда цикл прекратиться и возвратит значение функции в переменную answer в методе main.

0,0(0 оценок)
Ответ:
evelinastepenko
evelinastepenko
19.04.2022 17:40

 class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("Введите число a:");

          int a = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите число b:");

          int b = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите число c:");

           int c = Convert.ToInt32(Console.ReadLine());//Вводим 3 числа

           int sredAref = a + b + c / 3;//Считаем

           Console.WriteLine("Среднее Арифметическое : " + sredAref);// Выводим

           Console.ReadKey();

       }

   }

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота